CAdES
CAdES (CMS Advanced Electronic Signatures — Удосконалені електронні підписи CMS) — це набір розширень для підписаних даних із використанням криптографічного синтаксису повідомлень (CMS), що робить його придатним для використання в удосконалених електронних підписах.[1]
Опис
CMS — це загальна система електронних підписів для різних видів транзакцій, таких як заявки на придбання, контракти або рахунки-фактури.[2] CAdES визначає точні профілі підписаних CMS даних, що робить їх відповідними європейському регламенту eIDAS (Регламент про електронну ідентифікацію та довірчі послуги для електронних транзакцій на внутрішньому ринку). Регламент eIDAS розширює та скасовує Директиву 1999/93/ЄС про електронні підписи.[3][4] EIDAS є юридично обов'язковим у всіх державах-членах Європейського союзу з липня 2014 року. Електронний підпис, створений відповідно до eIDAS, має таку ж юридичну силу, як і власноручний підпис.[3]
Електронний підпис, технічно реалізований на основі CAdES, має статус удосконаленого електронного підпису.[2] Це означає, що:
- він однозначно пов'язаний з підписувача;
- він здатний ідентифікувати підписувача;
- лише підписувач контролює дані, що використовуються для створення підпису;
- його можна ідентифікувати, якщо дані, додані до підпису, були змінені після підписання.
Результуючою властивістю CAdES є те, що електронно підписані документи можуть залишатися дійсними протягом тривалого часу, навіть якщо підписувач або сторона, що перевіряє, пізніше намагається заперечити дійсність підпису.
Електронний підпис на основі CAdES приймається в судовому провадженні як доказ; оскільки вдосконалені електронні підписи мають юридичну силу.[5] Але він отримує вищу доказову силу, коли його посилюють до кваліфікованого електронного підпису. Щоб отримати такий юридичний статус, він повинен базуватися на електронному сертифікаті, зашифрованому за допомогою засобу створення захищеного електронного підпису («кваліфікований електронний підпис»).[4][6] Авторство твердження з кваліфікованим електронним підписом не може бути оскаржене — твердження є безвідмовним.
Документ ETSI TS 101 733 «Електронний підпис та інфраструктура (ESI) — CMS Advanced Electronic Signature (CAdES)» описує цю структуру.[2]
Еволюція фреймворку
Основним документом, що описує цей формат, є ETSI TS 101 733 «Електронний підпис та інфраструктура» (ESI) — CMS Advanced Electronic Signature (CAdES).
Стандарт ETSI TS 101 733 був вперше опублікований як V1.2.2 (2000–12). Поточна версія має номер випуску V2.2.1 (2013-04). ETSI працює над новим проектом CAdES. Усі проекти та опубліковані документи є загальнодоступними.[7]
ETSI TS V.1.7.4 (2008-07) технічно еквівалентний RFC 5126. RFC 5126 базується на існуючих стандартах, які широко прийняті. До них належать:
- RFC 3852 «Cryptographic Message Syntax (CMS)»
- ISO/IEC 9594-8/ITU-T Recommendation X.509 «Information technology — Open Systems Interconnection — The Directory: Authentication framework»
- RFC 3280 «Internet X.509 Public Key Infrastructure (PKIX) Certificate and Certificate Revocation List (CRL) Profile»
- RFC 3161 «Internet X.509 Public Key Infrastructure Time-Stamp Protocol (TSP)».
Профілі
Стандарт ETSI «TS 101 733» визначає формати для розширених електронних підписів, побудованих на CMS (CAdES). Він визначає низку підписаних та непідписаних додаткових властивостей підпису, що забезпечує підтримку низки варіацій вмісту підпису та вимог до обробки.
Для максимізації сумісності в спільнотах, які застосовують CAdES до певних середовищ, необхідно було визначити загальний набір опцій, що відповідають цьому середовищу. Такий вибір зазвичай називають профілем.
ETSI «TS 103 173»[8] описує профілі для підписів CAdES, зокрема їх використання в контексті Директиви ЄС про послуги, «Директиви 2006/123/ЄС Європейського Парламенту та Ради від 12 грудня 2006 року про послуги на внутрішньому ринку».
Доступні чотири профілі:
- CAdES-B: Базовий електронний підпис, найпростіша версія, що містить SignedInfo, SignatureValue, KeyInfo та SignedProperties. Цей рівень поєднує старі рівні -BES та -PES. Ця форма розширює визначення електронного підпису, щоб відповідати визначеній політиці підпису.
- CAdES-T: B-рівень, для якого постачальник довірчих послуг згенерував довірений токен (мітку часу або токен позначки часу), що підтверджує, що сам підпис фактично існував у певну дату та час.
- CAdES-LT: створюються шляхом безпосереднього включення до підписів CAdES-T, що відповідають T-рівню, атрибуту довгострокової перевірки, що містить значення сертифікатів та значення статусу відкликання сертифіката, що використовуються для перевірки підпису.
- CAdES-LTA: підпис, що відповідає LT-рівню, до якого включено один або декілька атрибутів довгострокової перевірки з poeValue. Використання періодичного позначення часу (наприклад, щороку) запобігає компрометації підпису, через ослаблення алгоритмів, протягом тривалих періодів зберігання. Цей рівень еквівалентний старому рівню -A.
Див. також
- ETSI (Європейський інститут телекомунікаційних стандартів)
- Синтаксис криптографічних повідомлень (CMS)
- XAdES — Удосконалений електронний підпис XML
- PAdES — Удосконалений електронний підпис PDF
- Пов'язані контейнери сигнатур (ASiC)
- Довірена мітка часу
Джерела
Примітки
- ↑ INTRODUCTION INTO CADES FOR TRUST SERVICE PROVIDERS / Dawn M. Turner // Cryptomathic : офіційний сайт. — Дата звернення: 01.03.2016.
- ↑ а б в Electronic Signatures and Infrastructures (ESI); CMS Advanced Electronic Signatures (CAdES) v. 4/2013 / European Telecommunications Standards Institute // www.etsi.org.
- ↑ а б EIDAS FROM DIRECTIVE TO REGULATION - LEGAL ASPECTS / Dawn M. Turner // Cryptomathic : офіційний сайт. — Дата звернення: 01.03.2016.
- ↑ а б REGULATION (EU) No 910/2014 OF THE EUROPEAN PARLIAMENT AND OF THE COUNCIL of 23 July 2014 / THE EUROPEAN PARLIAMENT AND THE COUNCIL OF THE EUROPEAN UNION // Official Journal of the European Union. — Дата звернення: 01.03.2016.
- ↑ UNDERSTANDING THE MAJOR TERMS AROUND DIGITAL SIGNATURES / Dawn M. Turner // Cryptomathic : офіційний сайт. — Дата звернення: 01.03.2016.
- ↑ Electronic Signatures and Trust Services / Department for Business, Innovation and Skills. — 2016. — 1 August.
- ↑ http://docbox.etsi.org/esi/Open/Latest_Drafts/
- ↑ ETSI TS 103 173.
Посилання
- RFC 5126 CMS Advanced Electronic Signatures (CAdES)
- RFC 3126 Electronic Signature Formats for long term electronic signatures
- All versions of ETSI TS 101 733 CAdES
- SecureBlackbox: Cross-platform library for creating and manipulating CAdES, XAdES, PAdES and ASiC Signatures
- XolidoSign desktop (Free. Supports Windows XP and above). Supports CAdES-BES, CAdES-C and CAdES-X-L. Available in 8 languages
- DSS: A free and open-source Java library for creating/manipulating PAdES/CAdES/XAdES/ASiC Signatures
- DSS : GitHub repository
- CAdES, XAdES and ASiC for Windows in C++
- The AdES toolset
Джерело: стаття у Вікіпедії та історія редагувань (автори).