YaChudo

Канальний рівень (TCP/IP)

Переглядів: 0. Оновлено 10.10.2026.

Рівні набору інтернет-протоколів із виділеним канальним рівнем

У комп'ютерних мережах канальний рівень (англ. link layer) є найнижчим рівнем у наборі інтернет-протоколів, мережевій архітектурі Інтернету. Канальний рівень — це група методів і протоколів зв'язку, обмежених каналом, до якої фізично підключений вузол. Канал є фізичним і логічним компонентом мережі, який використовується для з'єднання хостів або вузлів мережі між собою, а канальний протокол (англ. link protocol) — це набір методів і стандартів, які працюють лише між сусідніми мережевими вузлами мережевого сегмента.

Попри відмінності в семантиці рівнів між набором інтернет-протоколів та моделлю OSI, канальний рівень іноді описують як поєднання канального рівня даних (рівень 2) і фізичного рівня (рівень 1) моделі OSI.

Канальний рівень описано в RFC 1122 та RFC 1123. RFC 1122 відносить протоколи локальних мереж, такі як Ethernet та інші мережі IEEE 802 (наприклад, Wi-Fi), а також протоколи кадрування, такі як Point-to-Point Protocol (PPP), до канального рівня.

Визначення у стандартах і підручниках

Стандарти локальних мереж, такі як специфікації Ethernet та IEEE 802.3, використовують термінологію семирівневої моделі OSI, а не моделі TCP/IP. Модель TCP/IP загалом не розглядає фізичні специфікації; натомість вона передбачає наявність функціональної мережевої інфраструктури, здатної доставляти кадри на рівні середовища через канал. Тому RFC 1122 та RFC 1123, які визначають модель TCP/IP, не розглядають апаратні питання та фізичну передачу даних і не встановлюють стандартів для цих аспектів. Деякі автори підручників підтримували трактування, згідно з яким аспекти фізичної передачі даних є частиною канального рівня.[1][2] Інші припускали, що стандарти фізичної передачі даних не вважаються протоколами зв'язку і не є частиною моделі TCP/IP.[3][4] Ці автори припускають наявність апаратного або фізичного рівня нижче канального рівня, а деякі з них використовують термін канальний рівень даних замість канального рівня в модифікованому описі рівнів. У попереднику моделі TCP/IP — еталонній моделі ARPAnet (RFC 908, 1982) — аспекти канального рівня позначаються кількома нечітко визначеними термінами, такими як рівень мережевого доступу (network-access layer), протокол мережевого доступу (network-access protocol), а також мережевий рівень (network layer), тоді як наступний, вищий рівень називається міжмережевим рівнем (internetwork layer). У деяких сучасних підручниках терміни рівень мережевого інтерфейсу (network-interface layer), рівень вузол—мережа (host-to-network layer) та рівень мережевого доступу (network-access layer) використовуються як синоніми канального рівня або канального рівня даних, часто включаючи фізичний рівень.

Протоколи канального рівня

У моделі TCP/IP канальний рівень — це набір протоколів, які вузол використовує для обміну даними у безпосередньо підключеній мережі. Конкретний протокол канального рівня або протокол доступу до середовища залежить від використовуваної мережевої технології.[5] Кадри канального рівня доставляються локальною ланкою, а не маршрутизуються без змін через мережі; маршрутизація між мережами здійснюється на міжмережевому рівні шлюзами або IP-маршрутизаторами.[6]

До протоколів і засобів, пов'язаних із визначенням адрес канального рівня, належать Address Resolution Protocol (ARP), який зіставляє адреси протоколів, такі як IP-адреси, з адресами локальної мережі, такими як адреси Ethernet;[7] Reverse Address Resolution Protocol (RARP), який був визначений як протокол рівня каналу даних для отримання адреси протоколу за апаратною адресою;[8] та Neighbor Discovery для IPv6, який вузли IPv6 в одній ланці використовують для визначення адрес канального рівня і який частково відповідає ARP у IPv4.[9]

Зв'язок із моделлю OSI

Канальний рівень у моделі TCP/IP не відповідає точно одному рівню в моделі Open Systems Interconnection (OSI). RFC 1122 описує набір інтернет-протоколів як такий, що має рівні застосунків, транспорту, Інтернету та канальний рівень, і описує найнижчий рівень як протокол «канального рівня» або «рівня доступу до середовища», який використовується вузлом для обміну даними у безпосередньо підключеній мережі.[10] Натомість базова еталонна модель OSI розділяє функції нижчих рівнів на фізичний рівень і канальний рівень даних.[11] Унаслідок цього порівняння канального рівня TCP/IP із рівнями 1 і 2 OSI є приблизними, а не точними.

Різницю в класифікації можна побачити на прикладі таких протоколів, як Address Resolution Protocol (ARP). ARP було визначено для перетворення адрес протоколів, таких як IP-адреси, на адреси локальної мережі, такі як адреси Ethernet.[12] RFC 1122 розглядає використання ARP у мережах Ethernet та IEEE 802 як вимогу канального рівня.[13] Однак у термінології OSI ARP стосується як адресації мережевого рівня, так і адресації канального рівня даних, тому його розміщення не можна чітко визначити за допомогою суворої відповідності один-до-одного між двома моделями. RFC 3439 аналогічно застерігає від розгляду рівнів протоколів як суворих меж реалізації, зазначаючи, що структурована багаторівнева організація має концептуальні переваги, але також може накладати обмеження на порядок і збільшувати складність взаємодії між рівнями.[14]

Див. також

IETF стандарти

Примітки

  1. ↑ James F. Kurose, Keith W. Ross, Computer Networking: A Top-Down Approach, 2007 ISBN 0-321-49770-8
  2. ↑ Mark Dye, Mark A. Dye, Wendell, Network Fundamentals: CCNA Exploration Companion Guide, 2007, ISBN 1-58713-208-7
  3. ↑ Douglas E. Comer, Internetworking with TCP/IP: Principles, Protocols and Architecture, Pearson Prentice Hall 2005 ISBN 0-13-187671-6
  4. ↑ Charles M. Kozierok, "The TCP/IP Guide", No Starch Press 2005
  5. ↑ Braden, R., ред. (Жовтень 1989). Requirements for Internet Hosts -- Communication Layers. IETF. sec. 1.1.3. doi:10.17487/RFC1122. RFC 1122.
  6. ↑ Braden, R., ред. (Жовтень 1989). Requirements for Internet Hosts -- Communication Layers. IETF. sec. 1.1.1. doi:10.17487/RFC1122. RFC 1122.
  7. ↑ Plummer, D. (Листопад 1982). An Ethernet Address Resolution Protocol. IETF. doi:10.17487/RFC0826. RFC 826.
  8. ↑ Finlayson, R.; Mann, T.; Mogul, J.; Theimer, M. (Червень 1984). A Reverse Address Resolution Protocol. IETF. sec. III. doi:10.17487/RFC0903. RFC 903.
  9. ↑ Narten, T.; Nordmark, E.; Simpson, W.; Soliman, H. (Вересень 2007). Neighbor Discovery for IP version 6 (IPv6). IETF. sec. 3.1. doi:10.17487/RFC4861. RFC 4861.
  10. ↑ Braden, R., ред. (Жовтень 1989). Requirements for Internet Hosts -- Communication Layers. IETF. sec. 1.1.3. doi:10.17487/RFC1122. RFC 1122.
  11. ↑ 6. Information technology — Open Systems Interconnection — Basic Reference Model: The Basic Model (Звіт). International Telecommunication Union. Липень 1994. ITU-T Recommendation X.200; ISO/IEC 7498-1:1994.
  12. ↑ Plummer, D. (Листопад 1982). An Ethernet Address Resolution Protocol. IETF. doi:10.17487/RFC0826. RFC 826.
  13. ↑ Braden, R., ред. (Жовтень 1989). Requirements for Internet Hosts -- Communication Layers. IETF. sec. 2.3.3. doi:10.17487/RFC1122. RFC 1122.
  14. ↑ Bush, R.; Meyer, D. (Грудень 2002). Some Internet Architectural Guidelines and Philosophy. IETF. sec. 3. doi:10.17487/RFC3439. RFC 3439.

Джерело: стаття у Вікіпедії та історія редагувань (автори).